Heartbleed SSL Vulnerability

845 Views

On Monday April 7th it was revealed that there is a vulnerability in a popular SSL package called OpenSSL. Full technical details can be found at http://heartbleed.com/

The bug only affects very recent versions of openssl and only our cloud servers have a recent enough version of openssl to be affected. They have all now been patched.

You can use this tool to check if your site is vulnerable http://filippo.io/Heartbleed/ (only if you actually have SSL for your site)

Comments

Enjoy this post? Why not share with friends or add a comment of your own?

Share your thoughts…